pgAdmin 3

pgAdmin 3 es una herramienta de código abierto para la administración de bases de datos PostgreSQL y derivados (EnterpriseDB Postgres Plus Advanced Server y Greenplum Database). Incluye:

  • Interfaz administrativa gráfica
  • Herramienta de consulta SQL (con un EXPLAIN gráfico)
  • Editor de código procedural
  • Agente de planificación SQL/shell/batch
  • Administración de Slony-I

pgAdmin se disña para responder a las necesidades de la mayoría de los usuarios, desde escribir simples consultas SQL hasta desarrollar bases de datos complejas.

La interfase gráfica soporta todas las caracterísiticas de PostgreSQL y hace simple la administración. Está disponible en más de una docena de lenguajes y para varios sistemas operativos, incluyendo Microsoft Windows , Linux, FreeBSD, Mac OSX y Solaris.

pgAdmin III soporta versiones de servidores 7.3 y superiores. Versiones anteriores a 7.3 deben usar pgAdmin II.

Instalación pgAdmin3

En Linux (Ubuntu y derivados de Debian), instalar el paquete pgadmin3:

sudo apt-get install pgadmin3

En Windows, pgAdmin viene incorporado con el instalador de PostgreSQL, para instalarlo por separado descargar el zip y ejecutar pgadmin3.msi (ver sección Archivos)

Los instaladores, si bien son multilenguaje, generalmente hay que establecer que lenguaje usara la interfaz. Para ello ver sección Preguntas Frecuentes para conocer como configurar la interfase en español.

Ayuda en linea

Si presiona F1, cuando se editen propiedades de un objeto o consultas SQL, pgAdmin proporcionará ayuda sobre el comando SQL de PostgreSQL subyacente. Para que esto funcione correctamente, la configuración del sitio de ayuda SQL debe estar establecida correctamente. Ver sección Preguntas Frecuentes para conocer un método para configurar la ayuda en español.

Tutorial pgAdmin III

Este es un manual instructivo básico (paso a paso) en español (castellano) para usuarios principiantes que deseen conocer la herramienta pgAdmin III. Cubre las principales características, pero no abarca las funcionalidades avanzadas (para ello se recomienda instalar el programa y consultar la documentación en linea).

Para ingresar a pgAdmin III:

  • En Windows: menú Inicio, Programas, PostgreSQL, pgAdmin 3
  • En Linux: menú Programas, Programación, pgAdmin III

Ventana Principal

Una vez abierto pgAdmin III, la Ventana Principal muestra la estructura de la base de datos:

Ventana Principal

Consta de:

  • Barra de menú con las distintas funcionalidades de la herramienta
  • Barra de herramientas (que actuarán sobre los objetos seleccionados)
  • Explorador de objetos: árbol con las bases de datos definidas y su contenido
  • Panel de detalle: solapa de Propiedades, Estadísticas, Dependencias y Dependientes del objeto seleccionado
  • Panel SQL: sentencias SQL generadas mediante ingeniería inversa sobre el objeto seleccionado

Para abrir una conexión con un servidor de base de datos PostgreSQL, debe ubicarlo en el Explorador de objetos y hacer doble click o presionar la tecla Enter. Si no tiene registrado el servidor, deberá agregarlo.

Agregar Servidor

Para conectarse a un servidor, se debe agregar los datos del mismo mediante el botón Añadir una conexión a un servidor (ícono Pantalla de Agregar Servidor simil enchufe en la barra de herramientas), o la opción de menú Archivo, Añadir Servidor, con lo que aparecerá la pantalla de Nueva Registración de Servidor:

Pantalla de Nuevo Servidor

Completar:

  • Nombre: denominación de fantasía de la base de datos
  • Servidor: dirección IP o nombre de host
  • Puerto: número de puerto (usualmente 5432)
  • SSL: modo de encriptación de la conexión (requerir, preferir, permitir, desactivar, verificar de autoridad certificante, verificar completo)
  • Base de datos de Mantenimiento: conexión inicial, contiene adminpack y esquema pgAgent
  • Nombre de usuario: rol de postrges para la conexión
  • Contraseña: clave del rol de postgres para la conexión
  • Almacenar contraseña (para próximas sesiones). Importante: la contraseña se graba en un archivo de texto!
  • Restaurar env: almacenar y recuperar el entorno de navegación de pgAdmin
  • Restricción DB: limitar las bases de datos y esquemas que se muestran en pgAdmin
  • Servicio: parámetros para controlar el servicio (depende del S.O.)
  • Conectar ahora: intenta la conexión inmediatamente

Crear una base de datos

Para poder agregar tablas, es necesario crear primero una base de datos. Para ello, ubicar el item Bases de datos en el Explorador de Objetos, hacer click derecho y seleccionar 'Nueva Base de Datos' del menú contextual o ir al menú principal: Editar, Nuevo Objeto, Nueva Base de datos, aparecerá la pantalla de Nueva Base de Datos:

Pantalla de Nueva Base de Datos

Completar los campos principales:

  • Nombre: denominación de la base de datos (por simplicidad, evitar espacios, mayúsculas y acentos, separar con guión bajo '_')
  • Propietario: usuario (rol) que tendrá derechos especiales sobre la base de datos
  • Codificado: esquema de codificación (UTF8, LATIN1, WIN1252). Ver PreguntasFrecuentes para mayor información.

Presionar OK y se creará la base de datos.

Agregar una tabla

Para agregar una tabla, ubicar en el Explorador de Objetos, el esquema (schema) al cual pertenecerá (por defecto en Esquemas, public), y sobre el item Tablas hacer click derecho y seleccionar 'Nueva Tabla' del menú contextual o ir al menú principal: Editar, Nuevo Objeto, Nueva Tabla, aparecerá la pantalla de Nueva Tabla:

Pantalla: Tabla - Propiedades

De esta solapa propiedades, completar:

  • Nombre: denominación de la tabla (por simplicidad, evitar espacios, mayúsculas y acentos, separar con guión bajo '_')
  • Propietario: usuario (rol) que tendrá derechos especiales sobre la tabla

Luego, seleccionar la solapa Columnas:

Pantalla de Tabla - Solapa Columnas

Por cada columna a agregar presionar el botón Añadir:

Pantalla de Agregar Columna a Tabla

Completar:

  • Nombre: denominación de la columna (por simplicidad, evitar espacios, mayúsculas y acentos, separar con guión bajo '_')
  • Tipo de datos: seleccionar el tipo de datos (serial para autonuméricos, integer para enteros, character varing para textos variables, text para textos tipo memo, double precision para punto flotante, numeric para números con decimales precisos, etc.)
  • Longitud: para los tipos de datos de longitud variable (character, character varing, numeric, etc.) la cantidad de dígitos o caracteres totales.
  • Precisión: para los tipos de datos numéricos de precisión fija (numeric), la cantidad de dígitos decimales.
  • Valor por defecto: un dato predeterminado que se usará si al ingresar un registro no se especifica ningún valor para la columna.

Luego de agregar las columnas, agregar las clave primaria y foráneas mediante la solapa Restricciones:

Pantalla de Tabla - Solapa Restricciones

Seleccionar Clave Primaria (primary key) y presionar Añadir, aparecerá la pantalla para definir la clave primaria:

Pantalla de Tabla - Restricciones PK - Propiedades

Completar:

  • Nombre: denominación de la restricción (ej. mi_tabla_pk)

Seleccionar solapa columnas, elegir la columna que forma parte de la clave primaria y presionar Añadir:

Pantalla de Tabla - Restricciones PK - Solapa Columnas

Una vez definida la clave primaria, en la solapa Restricciones, seleccionar Clave Ajena (foreing key) y presionar Añadir, aparecerá la pantalla para definir una clave foránea:

Pantalla de Restricciones - Solapa Propiedades

Completar:

  • Nombre: denominación de la restricción (ej. mi_tabla_fk_otra_tabla)
  • Referencia: elegir la tabla foránea (la cual posee la clave primaria a verificar)

Seleccionar solapa columnas, elegir la columna que forma parte de la clave foránea y presionar Añadir:

Pantalla de Restricciones - Solapa Columnas

Herramienta de edición de datos

La grilla de edición permite ver y editar los datos seleccionados en una tabla o vista. Para ello, seleccionar la tabla o vista en el Explorador de Objetos y luego presionar el botón Ver los datos del objeto seleccionado (ícono Botón Grilla simil grilla) de la barra de herramientas o por el menú Herramientas, Ver Datos:

Pantalla de Edición de Datos

Para editar, hacer doble click en la celda a modificar. Los ítems principales de la barra de herramienta son:

  • Guardar (ícono Botón guardar simil disquete): almacena los datos modificados
  • Eliminar (ícono Botón eliminar simil basurero): borra la fila seleccionada
  • Refrescar (ícono Botón refrescar simil reciclado): actualiza la grilla con datos recientes (por ejemplo, número de secuencia)

Importante: solo se puede actualizar datos (modificar y borrar) si la tabla cuenta con una clave primaria.

Herramienta de Consulta SQL

Al seleccionar una base de datos, se habilita la herramienta de consulta, que permite ejecutar consultas SQL arbitrarias. Para ingresar a dicha herramienta, presionar el botón Ejecutar consultas SQL arbritrarias (ícono Botón herramienta de consulta SQL simil hoja, sql, lapiz) de la barra de herramientas o dirigirse al menú Herramientas, Herramienta de consulta (Ctrl+E).

Pantalla de Herramienta de Consulta

Funcionalidades importantes:

  • Ejecutar consulta (ícono Botón ejecutar simil Play)
  • Exportar datos consulta (ícono Boton exportar simil Play con Disquete): para guardar las filas resultantes (ver siguiente)
  • Analizar consulta (ícono Botón EXPLAIN simil árbol): para mostrar un EXPLAIN gráfico (explicación visual de los nodos del plan de ejecución de la consulta)

Constructor Gráfico de Consultas

A su vez, la herramienta de consulta posee una solapa para diseñar consultas visualmente (similar a Access y otras herramientas), llamado Constructor Gráfico de Consultas:

Pantalla del Constructor gráfico de consultas

  1. En el panel superior izquierdo aparecerán la base de datos, con sus esquemas, los cuales una vez abierto (por ej. public) mostrará un arbol de las tablas disponibles.
  2. Al hacer doble click en la tabla, aparecerá en el panel superior derecho, con la posibilidad de arrastrar y unir sus campos con los de otra tabla, para construir las juntas (joins). También se debe seleccionar la columna a mostrar como resultado de la consulta.
  3. En el panel inferior, se encuentran las solapas de Columnas (para detallar las columnas de salida del SELECT), Critero (para incluir condiciones WHERE), Ordenamiento (ORDER), y Juntas (para especificar los tipos de JOIN)

Herramienta de Exportación

La herramienta de exportación permite exportar datos de la herramienta de consulta. Para ello, en la herramienta de consulta, presionar el botón Ejecute consulta, escriba resultado en archvio (ícono Boton exportar simil play con disquete) de la barra de herramientas o mediante el menú Consulta, Ejecutar a un archivo:

Pantalla de exportación

Se debe completar el nombre del archivo y demás datos, y una vez generado dicho archivo, se puede abrir con cualquier planilla de cálculo (Gnumeric, OpenOffice?, Excel).

Herramienta de Resguardo

La herramienta de resguardo (backup) llama a la herramienta de volcado de PostgreSQL para crear copias de seguridad de los datos. Para utilizarla, seleccionar la base de datos del Explorador de objetos, presionar botón derecho y elegir Resguardar (o menú Herramientas, Resguardo):

Pantalla para Resguardar

Completar los campos principales:

  • Nombre de archivo:
  • Formato: COMPRESS (binario comprimido), PLAIN (textual sin comprimir), TAR (archivador)
  • Opciones:
    • Blobs: incluir objetos grandes
    • Comandos INSERTs: generar sentencias INSERT en vez de COPY

Presionar OK y se generará el archivo con la copia de seguridad (backup) de los datos seleccionados.

Herramienta de Restauración

La herramienta de restauración (restore) llama a la herramienta homónima de PostgreSQL para restaurar los datos desde copias de seguridad (archivos de backup) Para utilizarla, crear una base de datos en blanco (ver arriba), seleccionarla en el 'Explorador de objetos, presionar botón derecho y elegir Restaurar (o menú Herramientas, Restaurar):

Pantalla para Restaurar (restore)

Completar los campos principales:

  • Nombre de archivo: ubicación de la copia de seguridad
  • Solo datos: si solo se desea restaurar los datos, no el esquema de tablas
  • Objeto individual: si se quiere restaurar solo una tabla específica (ver solapa Contenido)

Presionar OK y leerá el archivo con la copia de seguridad (backup) restaurando los datos. En caso de éxito, el botón cambiará a Hecho, en caso de falló permanecerá en Ok para volver a restaurar (algunos de los fallos son triviales y pueden ser ignorados, por ej., al crear un lenguaje que ya existe.)

Nota: con esta herramienta solo se pueden restaurar copias de seguridad comprimidas (formato COMPRESS)

Herramienta de Mantenimiento

Esta herramienta de mantenimiento (maintance) ejecuta la tarea de reconstruir las estadísticas sobre la base de datos y tablas, limpiar los datos no utilizados y reorganizar los índices. Para utilizarla, seleccionar la base de datos del Explorador de objetos, presionar botón derecho y elegir Mantenimiento (o menú Herramientas, Mantenimiento):

Pantalla de Mantenimiento

Opciones de mantenimiento:

  • VACUUM: limpieza de las tuplas muertas
  • ANALYZE: analizar los datos para calcular estadísticas
  • REINDEX: reorganizar los índices

Opciones de VACUUM:

  • FULL: compactar la tabla . Cuidado: esta operación bloquea la tabla, no es recomendada en producción.
  • FREEZE: "congelamiento" agresivo de las tuplas
  • ANALYZE: analizar los datos para calcular estadísticas

Para más información ver comandos VACUUM y ANALYZE

Herramienta de Estado del Servidor

La ventana Estado del Servidor mostrará los usuarios actualmente conectados, bloqueos, transacciones preparadas y el archivo de bitácora (logs) del servidor de base de datos seleccionado. Para utilizarla, seleccionar el servidor en el Explorador de objetos, ir al menú Herramientas, Estado del Servidor):

Pantalla de estado del servidor

Funcionalidad:

  • Cancelar consulta (ícono Botón para Cancelar Consulta): envía la señal para cancelar la consulta seleccionada
  • Terminar backend (ícono Botón para Terminar un proceso de backend): envía la señal para finalizar el proceso servidor seleccionado

Autor: MarianoReingart, con algunos textos extraidos y traducidos del sitio oficial de pgAdmin.

Attachments